
Window Layouts 

 

ShareScope User Guide  Page 1 of 14 

 
 

Chapter 5 - Windows Layouts  

 

 
 
 
 
 
 
 
 
 

This chapter is for ShareScope Plus and Pro users only. We recommend that you read 
the preceding chapter – Navigation – first. 
 
 

What you will learn in this chapter: 
 
 About window layouts. 

 How to identify the contents of a window. 

 How to create a new window. 

 How to move and resize windows. 

 How to link windows to other windows. 

 How to drag windows outside ShareScope onto another screen (float windows) 

 How to create additional layouts. 

 How to rename and copy window layouts. 

 How to lock windows and layouts. 

 How to save and restore window layouts. 

 How to reset window layouts to the default settings. 
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Windows in ShareScope Plus & Pro 
 

ShareScope Plus & Pro have a multi-window format which enables you to display multiple views 
simultaneously. The arrangement of windows on the ShareScope screen is called a Window Layout and can 
consist of one or more windows. You can customise the layout to contain the information you are 
interested in.  

The layout on the screen when you first open the program is called Main layout and consists of a List, two 
Intraday Graphs, a News window and a Details window. ShareScope is provided with seven preset layouts 
and five blank layouts you can easily switch between. You don’t need to keep the preset layouts – we 
suggest that you customise them to suit your requirements.  
 
You can create additional window layouts if you need more than the original twelve. 

There are buttons on the toolbar at the top of the ShareScope screen that represent the 7 preset layouts. 
The 8th button, My Layout, is one of the blank layouts. 

 

Try clicking on the different layout buttons to see how the windows are arranged and the information they 
contain is presented 

Below are two examples of more sophisticated window layouts: 
 

 
 
Within each layout, the windows can be resized, moved, maximised and minimised. You can also add new 
windows, change the contents of a window, or remove windows. 
 
You can use ShareScope across multiple screens and/or you can “float” windows so that they can be 
dragged outside of the main ShareScope application window. 
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The window title bar 
If you are not sure what a window contains – look at its title bar: 
 

 
 
In this example: 
 

01   this was the first window created in this layout.    
List: FTSE 350  this is the currently selected list of instruments in this window. 
All sectors  this list is not currently filtered by sector. 
Main View Main View is the table setting that has been applied to this window.  
(Linked)   this window is linked to another.    

The Active Window 
In a multi-window layout, any actions you perform will apply to the active (or selected) window. To make a 
window the active window, simply click on it. The active window will have a darker title bar and border. 
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In the example above, the active window has a red frame. You can customise the active window frame 
colour. 
 
Click on the Tools menu and then Options. On the Layouts tab look for the section called Captionless 
windows.  
 
The first option, Active window frame colour, allows you to set the colour of the window border if the title 
bar has been hidden.  
 
The second option, Use for all active windows, will use the Active window frame colour for the current 
window regardless of whether its title bar can be seen or not. 
 

Customising a window layout 
Straightaway you’ll probably want to customise one or more window layouts to suit your requirements.  
As you have seen, there are buttons for the first eight window layouts on the toolbar at the top of the 
ShareScope window. If you wish to start creating your own layout you can click on the My Layout button. 
Alternatively you can access all the available Window layouts: click on the Window menu and then 
Window layouts: 
 

 
 

Moving and resizing a window 
Windows can be moved around the ShareScope screen by dragging them by their title bar.  If the title bar 
has been hidden then there are a series of dots in the centre of the border at the top of the window.  The 
mouse will change to a four-way arrow and you can then drag the window around the screen. 
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You can resize windows by placing the mouse cursor at the edge of the window until the cursor changes to a 
multi-directional arrow and then dragging the window in to the desired size and shape. 
 
The sides of a window allow you to resize either the horizontal or vertical aspect while the corners of the 
window allow you to resize both at the same time. 
 

 
 
Create a New Window 
To add a new window to your layout, click on the Window menu and then the New Window sub menu. 
Select the type of view you wish to display.  Notice that there isn’t an option for a List view. Instead, there 
are options for the All list (all instruments), Shares list (all shares) and Other fixed list (which is a submenu 
of list of specific data sets (e.g. FTSE 350, Foreign Exchange, Unit Trusts...).  
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Change the List in a List window 
To change the list of instruments in a List window, click on the Window menu (or right-click in the window’s 
title bar) and select Change list. Select from the submenu of fixed lists shown below. 
 

 
 
Change the window view 
In any window, you can change the view. Click on the Window menu (or right-click in the window’s title bar) 
and select Change window. Select the required view from the submenu (shown below): 
 

 
 

The options in the Change window submenu which are prefixed with “Share’s …” will load data specific to 
the currently selected instrument. For example, to display a share’s news you would select Share’s News; to 
display all news stories, you would select News. You will notice that there is no specific option for List. 
Instead, there are options for All (all instruments), Shares (all shares) or Other fixed lists (which displays a 
submenu of all ShareScope’s lists). 
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Remove a window 
To close a window and remove it from your layout either click the cross at the top right hand corner of a 
window or select the window and from the Window main menu select Close current window.  
 

Remove all windows 
To close all windows - leaving a blank layout – click on the Window menu and select Close all windows.  
 

Linking windows 
You can link windows together so that information for the same instrument is displayed simultaneously in 
any number of windows in the same layout. Once one or more windows have been linked, changing the 
instrument in any of the windows will cause the others to change automatically. You can link as many 
windows together as you wish, and have multiple sets of linked windows.  
 
Most windows in ShareScope can be linked together. However, in a group of linked windows, list and 
portfolio windows will show the same list or portfolio. This enables you to display lists using two different 
tables – for example, technical in one window and fundamental in another. Note that you can’t link two 
data mining windows together – as they will generate different lists of instruments. 
 
To link a window, right click on the title bar of the window and select Link window from the context menu. 
 

 
 
This will launch the Link window dialog. The dialog box contains a list of available windows to link to, by 
window title. In the example below, View 03 – “List: FTSE 100 – All sectors” is the available window, with 1 
other window already currently linked to it. Double click on the window you wish to link to in the list to 
complete the linking.  

 
 
The title bar of a linked window will include “(Linked)” at the end to indicate it is linked in to a set.  
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Unlinking a Window 
To unlink a window, right click on the window title bar and select Unlink window.  
 

Autolink windows 
AutoLinking is an extension to Linking windows. Windows that show information for a single instrument 
(e.g. Historical Graph, Details) can be autolinked to several lists. The autolinked window will display 
information for the selected instrument in the current selected window.  
 
For the purposes of autolinking, lists include News windows in which you could click on a story relating to a 
specific share and the Alarms window where can select an alarm has been set on a specific share. 
 
Similarly, a Transactions or Cash Account window may be autolinked to multiple Portfolio windows. Here 
the autolinked window will display the transactions or cash account for the selected portfolio. If more than 
one cash account is attached to the portfolio, you can select them in sequence by right-clicking in the 
autolinked Cash Account window and selecting Next linked cash account.  
 
To autolink a window to other windows, right-click in the window title bar (or on the window frame if the 
title bar is hidden) and select AutoLink. The window will be linked to all other relevant windows in the 
layout. It will initially display the instrument selected in the window that was active last. 
 
Autolinked windows display an @ symbol before the window title instead of a window number (e.g. @ 
Historical Graph – 1 Day Candles). 
 

 
 
Note:  

1. Windows may be linked or autolinked but not both.  
2. You can't autolink List, Portfolio or Data Mining windows. For example, if you have three List 

windows and one Graph window in a layout, it is the Graph window that must be autolinked.  
3. If an instrument is selected for which no relevant information can be displayed in the autolinked 

window (e.g. a portfolio which has no attached cash account), then the autolinked window will not 
change.   

4. Windows such as News or Alarms, which can show either all items or those relating to a single 
share, will always show only the share's items when auto-linked.  

5. Searching for an instrument in an autolinked window will search the window that it is currently 
autolinked to e.g. the last selected list window. 

 

Floating windows 
Floating windows are windows that you can "detach" from the ShareScope program. That is, you can move 
them outside of the program window and on to other screens for example. 
 
To enable floating windows: 
 

1. Go the Tools menu and click on Options. 
2. Click on the General tab and then click on the Multi-screen and floating windows Set options 

button. 
3. Click on Enable floating windows. 
4. Optionally, click on Float new windows by default if you want all new windows to be "floating". 
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To float an existing window, right-click in the title bar of the window and select Float window. If this option 
already has a tick next to it then the window is already floating. 
 
To move the window, click and drag the window's title bar - or on the "gripper" (dotted line) if you have 
hidden the window's title bar. 
 
Floating windows have a ShareScope icon on the left-hand side of the title bar (unless you have hidden the 
title bar). If you have hidden the title bar of the window, the dotted line (gripper) at the top of the window 
will change to a double dotted line. Each floating window will also appear on your computer's task bar.  
 

 
 
To unfloat a window, simply select the Float window option again (the tick will be removed). You can also 
do this by right-clicking on the task bar icon and selecting Dock window (in Windows XP and Vista). With 
Windows 7, move your mouse over the ShareScope task bar button. Then right-click on the image of the 
floating window and select Dock window. 
 
Keep window on top - This functionality enables you to ensure that a specific window always remains on 
top of other applications. Right-click in the window's title bar and select Keep on top. A tick will appear next 
to the option. To disable this feature, simply select the option again (the tick will be removed). 
 

Keep window open - By default, floating windows will be linked to the current window layout. However, 
you can configure floating windows to be independent of the window layout. For example, you might want 
a market news window to be open at all times. Right-click on the window's title bar (or top border) and 
select Keep window open. Such windows can be identified by their narrow green border and inverted 
colouring on the close window icon (cross). 

 

 

Permanently open windows cannot be linked to normal windows. 

However, you can configure multiple windows to be permanently open and they can be linked together. 
This creates an additional floating layout. This layout can be locked using the Lock features (click on the 
green padlock in the window's title bar). 
 

Remove a window’s title bar 
Windows can have their title bars removed to save space in the ShareScope screen. To remove a title bar 
from a window, right click on the title bar and from the context menu that appears select Show title bar. 
While the title bar is enabled the option will appear with a tick preceding its name in the menu. To re-
enable the title bar, right click on the border of a window and follow the same steps as above. The cursor 
will change to a directional-arrow when you’re hovering over the window border.  
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With title bar displayed. 

 

 
With title bar hidden. 

 
 

Window layouts 
 
Create additional layouts 
You can either create a new blank layout or you can copy an existing layout. Go to the Window menu, then 
Window layouts and then New window layout.  

 

 
 

You can choose Make blank layout or Copy current layout.  You will are able to enter a descriptive name for 
the new layout. There is also an option to automatically add a button to the toolbar for the new layout. The 
button is added alongside the other Layout buttons. 

 

Rename a window layout 
You may find it helpful to give each layout a descriptive name. Click on the Windows menu and then 
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Window layouts. Select Rename window layout. A dialog box will appear prompting you to change the 
name. The current layout name will be present to remind you which layout you are naming.  
 
Copying a window layout 
You can also create a new layout based on an existing one by creating a copy. Note that you will need to 
copy the layout to a blank layout or overwrite an existing layout.  
 
First select (display) the layout you wish to copy. Then click on the Windows menu and then Window 
layouts. Select Copy this window layout. The Save layout to another location dialog will appear. The layout 
which is currently active in the ShareScope screen will be greyed out. To select the layout that you wish to 
save to, select from the bulleted options. You can also specify a new name for the layout or use the default 
(usually the original name with ‘copy’ on the end).  
 

 
 

Saving and Restoring Layouts 
ShareScope automatically saves all layouts when you close the program. You can also save a layout 
manually. This is useful if you have your layout as you wish but want to create a point from which 
ShareScope can restore your layout if you want to experiment further. Once you have saved a layout, you 
can restore it to its original state after making any changes. Similarly using the restore option will revert a 
layout back to how it was when you started ShareScope, unless you have saved since. Save and restore 
options can be found under the Window main menu: Windows layouts: Save and Restore sub menu.  
 
Resetting a Preset Layout 
If you have altered one of the preset layouts, you can restore it to the default configuration - as it was when 
you first installed ShareScope. In fact, you can reset any layout to one of the preset configurations. 
 
First, display the layout that you want to reset. Next, click on Windows, then Window layouts, then Default 
window layouts. The following dialog will be displayed: 
 

 
 
Select the first option to reset all layouts to their default configuration. Otherwise, select the preset layout 
that you want to apply to the current setting. 
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Locking a Window or Layout 
 
You can lock a window or layout in ShareScope to prevent accidental changes to your current configuration.  

Notice the padlock button in the top right corner of each window (next to the Close window button). A blue 
padlock button indicates no locking and a red padlock button indicates that at least one feature has been 
locked.  

Lock Window  
Click on the Padlock icon in the top right hand corner of the window. If the window title bar has been 
removed, you can access the lock options from the Window menu. From the menu, select Lock window. 
 

 

 
The Lock Windows dialog allows you to select options that will prevent changes to this window, and if you 
wish, all windows in the current layout or windows in all layouts.  
 

 
 
First select the Lock Window tick box. Then select the options you require: 
 

Moving, resizing & 
deleting 

The window cannot be moved, resized or deleted. You can still maximise and 
restore the window.  

View  The view cannot be changed. I.e. If the current locked window displays a List 
View, this cannot be changed to another, like, for example the Graph View.  

List  The underlying source-list cannot be changed.  

Setting / Table The setting or table applied to the window cannot be changed. I.e. you cannot 
select from the twelve settings or tables. You can however edit the current 
setting.  

Share  The currently selected share cannot be changed using the keyboard arrow keys 
or space bar. You can only change the share using the Find a Share dialog.  

Then decide if you want to apply the locking options to all the windows in the current layout or all layouts. 
If you just want to lock the current window then leave these two options unticked. 

mk:@MSITStore:C:/SHARES~2/ShareScope.chm::/topics/HID_HELP_FIND.htm
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To remove the lock, return to this dialog box and un-tick Lock Window.  

Lock Layout 
This option enables you to prevent accidental changes to any windows within the current layout or to any 
layouts.  

Click on the Padlock icon in the top right hand corner of the window (next to the Close window button). If 
the window title bar has been removed, you can access the lock options from the Window menu.  

 

From the menu, select Lock layout.   

 
To prevent changes, first select the Lock Layout tick box. Then select what you would like to prevent being 
changed: 
  

 
 
 

Moving, adding or 
closing windows 

The windows in the layout are fixed. You can not move, resize, close or add a 
window to the layout. 

Linking between views The linking between windows can not be changed. You can not add, delete or 
modify existing window links. 

View - the type of 
window 

The view type in all windows in the layout can not be changed. 

Underlying list The underlying list in all windows can not be changed.  

Selected/Table The settings and tables used in all windows can not be changed.  

  
To apply the changes to the current layout, Click OK. Alternatively to apply your selection to all layouts, tick 
Apply to all layouts.  
  
To remove the lock, return to this dialog box and un-tick Lock Layout.  
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Other Window Commands 
 

You can also arrange windows on the screen using commands from the window main menu. These become 
useful when creating your own layouts, which will be explained later. 
 

 Arrange windows – will arrange the windows on your screen to best fit the screen. Windows are 
expanded or reduced to fit the screen to reduce the amount of wasted screen space. The best way 
to use this is to roughly arrange windows on your screen so that they are approximately the size 
and in the position you require them.  

 

 Cascade – will resize all windows to the same size and then cascade them. Useful for reviewing each 
window, one at a time, in detail.  

 

 Tile horizontally – arrange windows to fit the ShareScope screen in rows. Windows will tend to be 
wider after this process. 

 

 Tile vertically – arrange windows to fit the ShareScope screen in columns. Windows will tend to be 
taller after this process. 

 

 


