
 Tutorial 26 – Alarms

Version 5.3 of ShareScope included a major upgrade to the Alarm feature in the program,

providing enhanced functionality for both end of day and intraday alarms.

In this tutorial:

Setting an alarm

Setting an end-of-day alarm

Setting an Intraday alarm (ShareScope Plus/Pro)

List and Portfolio Alarms

Reviewing Alarms

Deleting Alarms

Triggered Alarms (ShareScope Gold)

Triggered Alarms (ShareScope Plus/Pro)

View Triggered Alarms

Re-triggering Alarms

Deleting Alerts

View Cycling

Linking Windows (ShareScope Plus/Pro)

Alarm options

The Alarms suite can be categorised into the following two areas:

Alarms lists all the alarms currently set.

Alerts – triggered alarms lists only the alarms that have been triggered.

To move between the two, use the View menu in ShareScope Gold or View: Change Window in

ShareScope Plus/Pro.

In ShareScope Plus/Pro you may find it useful to set up a new layout which has these views on it.

Alternatively, you can customise your toolbar and add buttons to

quickly change between views. See Tutorials 11 and 21 for

information how.

Note: If you have added these buttons to the toolbar in ShareScope Plus/Pro, clicking them will

change the current window to the selected view; holding the shift key and clicking them opens

the selected view in a new window.

 Setting an alarm

You can set an alarm on an individual share, on a selected list of shares or on all shares within a

portfolio. To set an alarm select one of the following from the Edit menu:

On an individual share or the parent list.

ShareScope Gold ShareScope Plus/Pro
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On an individual share or the current portfolio.

ShareScope Gold ShareScope Plus/Pro

You can also set an alarm on a selected share from the context menu.

ShareScope Gold:

Right click in a list view and select from the context menu Set an

alarm for...

We will cover Share's Alarms and Share's Alerts in more detail later in this tutorial.

ShareScope Plus/Pro:

Right click on a share in a list view and select from the context menu Set alarm on share, then

choose between an intraday or end-of-day alarm.

Alarms can also be set from toolbar buttons. Please refer to

Tutorial 11 and 21 for information on how to customise the

toolbar.

Note:In ShareScope Plus/Pro setting alarms from the toolbar buttons will default to setting an

intraday alarm.

Once you have selected to set an alarm you will see a wizard similar to the examples below,

depending on the type of alarm you have chosen.

 Setting an end-of-day alarm

This alarm will trigger after the markets have closed and ShareScope has updated its data.

You can set alarms for a wide range of events. The latest release of ShareScope (5.3) has added

the ability to set alarms on Director's dealings, News stories, Moving averages, MACD, RSI

and Stochastic, as well as the previous alarm types.

Example:
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In this example we will select Price rise / fall.

At this point you can also configure end-of-day alarm options using the Options button or navigate

< Back to change the share/list you are setting an alarm for.

Select Next to continue setting an alarm for your chosen share.

With the latest upgrade to alarms in ShareScope, new parameters are available to trigger price

rise / fall events in addition to the existing ones; you can now specify open, high, low and

stop-gain criteria; and stop-loss and stop-gain can now be specified from a start date.

In this example we have set the alarm to be triggered if the Close falls by 5% in 1 day.

If you make a mistake or wish to change an option on the previous screen use the < Back button.

To save and add another alarm to the same share click Add now. To save and exit the alarm

wizard click Finish.

 Setting an Intraday alarm (ShareScope Plus/Pro)

You can set an intraday alarm in the same way as an end-of-day alarm. These alarms will trigger
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while you are connected and receiving intraday data. For ShareScope Pro users, this enables you

to react to events as they happen.

The latest event types to be added to intraday alarms include:

Unscheduled auctions

Bid / offer / trade price rise or fall

In the following example we have set an alarm to trigger if an unscheduled auction takes place.

At this point you can also configure intraday alarm options using the Options button or navigate <

Back to change the share/list you are setting an alarm for, or even further back to change to an

end-of-day alarm.

The final stage of setting an intraday alarm is to specify how you would like to be notified of a

triggered alarm. The new ways in which you can be notified include pop-ups, sounds and the

ability to be alerted by email.

Once you have made your selection, click Finish.

For further help on the types of alarms you can set and the different alert options press F1 while in
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the Wizard at any time.

 List and Portfolio Alarms

To set an alarm on a list or portfolio of shares change your view to the list or portfolio you require.

From the Edit menu select Set an alarm for ___ list or Set an alarm for portfolio '___'.

In ShareScope Plus/Pro this can be an end-of-day alarm or an intraday alarm.

In this example the option to: Set an end-of-day alarm for the FTSE 100 list of shares has

been selected.

In ShareScope Gold this will appear as:

The Alarms Wizard will take you through the steps to configure the alarm.

 Reviewing Alarms

To review your current alarms, change to the Alarms view. You can select it from the View menu

in ShareScope Gold and View: New Window in ShareScope Plus/Pro.

When you open the Alarms view in this way, it displays all alarms for shares and lists/portfolios.
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In this example there are five alarms set up for individual shares and one alarm set for list (the

FTSE 100).

To view just the alarms for a single share select the share from a list view, right click to bring up

the context menu and select Share's Alarms.

In this example, 3i Group PLC has three alarms set, two individual alarms and one list alarm (set

from the FTSE 100 list).

From here you can perform actions on your alarms. Right click to bring up the context menu to

edit, delete, copy, add new and show either end-of-day or intraday alarms (in ShareScope

Plus/Pro).

To edit an alarm, double left click on the alarm to bring up the alarms wizard. You can now amend

the existing alarm properties.

 Deleting Alarms

To delete alarms from the Alarms view, highlight the alarm you wish to delete, right click and

select Delete Alarm. You will be prompted to confirm your choice. Deleting an alarm also deletes

all associated alerts.

You can delete all alerts associated with an alarm without deleting the alarm by highlighting the

alarm, right clicking and selecting Delete all alerts for this alarm.

 Triggered Alarms (ShareScope Gold)

In ShareScope Gold an alert summary dialog will notify you of how many alerts you have by

event type. This is displayed after you have performed an update.

In the first example, one alert has been generated from a triggered alarm.

In the second example, two different alarm types have been triggered multiple times.
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To dismiss the alert summary dialog click OK. For a list of the current alerts click Show Alerts view.

 Triggered Alarms (ShareScope Plus/Pro)

In ShareScope Plus/Pro you will be notified by the means you selected through the Alarms Wizard.

The default way in which you will be alerted is by a pop-up message.

To dismiss pop-up alerts click OK. If an alarm for a portfolio or list has been triggered you will

receive an alert for each individual share that matched the alarm criteria. In this instance you can

click Cancel all to dismiss all pop-ups associated with this alarm, on screen and those that have

yet to appear.

The number of pop-ups that can appear on your screen when an alarm has been triggered is set in

the Intraday alarms options.

To set this go to Tools: Options: Intraday alarms and select the number of pop-up alerts from

the Maximum number of pop-up alerts drop down box.

 View Triggered Alarms

To view alerts for triggered alarms select Alerts – triggered alarms from the View menu in

ShareScope Gold and from View: New Window in ShareScope Plus/Pro.

New alerts appear in bold and contain an asterisks (*) in their New column. An alert will remain in

the list of alerts until it is deleted.

To see details of a selected alert, simply double left click on the alert. All alerts except news alerts

and line alerts will open the Alert management dialog. News alerts will open the associated news

article that triggered the alarm and graph alerts will take you to a graph of the share.

The action of double left clicking will also mark the alert as read, consequently removing the bold

formatting from the alert and the asterisks (*) from the New column.
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From the Alert management dialog you can also Delete alert, Delete alarm and Edit alarm.

Please refer to corresponding topic in this tutorial or ShareScope help for further information on

these buttons.

Once you have finished click Acknowledge to return to the list of alerts.

Right clicking on the selected alert will bring up the context menu where you can perform similar

actions to the Alert management dialog. You can also perform actions on all alerts from the context

menu such as Mark all alerts read and Mark old alerts read.

To perform an action on a selection of alerts hold the shift key while selecting a continuous group

of alerts or hold the Ctrl key while selecting individual alerts to form a group. Right click on any

alert within the group and select an action to be performed from the context menu.

The Alerts view can be restricted to show just end-of-day, intraday,

all and new alerts. Right click in the Alerts view and select

Show... and then your choice of filter.

 Re-triggering Alarms

An end-of-day alarm will re-trigger the following market day regardless of whether the alert(s) for

the previous day(s) has been read or not.

An Intraday alarm will re-trigger when you have read the existing share's alert generated by the

alarm, the conditions of the alarm have been satisfied again, and the time between re-triggering

has elapsed.

To set the time between an alarm re-triggering go to: Tools: Options: Intraday alarms and

check the option Interval after alert is read before alarm can retrigger. You can then specify

a time in minutes.

 Deleting Alerts

To delete an alert from the Alerts view, select the alert(s) you wish to delete, right click on the

alert and select Delete Alert.

Further deleting options are available from the Delete sub-menu.
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In this example we are deleting all old alerts. Old alerts are either intraday alerts or end-of-day

alerts triggered before the current day.

You can also delete alerts from the Alarms view.

 View Cycling

ShareScope's normal view cycling is available in the Alerts view but not the Alarms view because

an alert is always related to a single share, while alarms can be related to entire lists and

portfolios.

The Alerts view takes the place of the List view.

To cycle between views use the Enter key to cycle forward and Esc (or shift enter) to cycle

backwards.

 Linking Windows (ShareScope Plus/Pro)

You can link both the Alarms window and the Alerts window to other windows such as the List,

Detail or Graph window in ShareScope Plus/Pro.

The above example displays a FTSE 100 list and an Alarms window showing current alarms. Linking

these windows allows you to see the alarms that are set for share for FTSE 100 stocks.

To link windows, right click on the blue title bar (in this case "03 List: FTSE 100") and then select

Link window....

The Link window dialog will appear with the available windows for linking. Select the window you

wish to link to by left clicking on it in the list.
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Note that the FTSE 100 List window itself will not appear in the Link window dialog.

In this example we select View 02 - “Alarms – Alarms table 1”. The “View 02” may appear as

a different view number in your ShareScope.

The result is a list window which we can select shares from and immediately see current alarms set

for that share in the alarms view.

As can be seen in this example, BG Group PLC has been selected in the FTSE 100 List window and

the Alarms window has refreshed to show those alarms set for the share.

You can also link the Alerts window in the same way. Linking the Alerts window will show you the

current alerts for the selected share.
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In this example the Alert window is linked to the Alarm window. By selecting an alarm in the

Alarms window the alert for the selected alarm will appear in the Alerts window.

To unlink a window, right click on the title bar and select Unlink window. You can also reach this

option by selecting a window and going to Window on the menu bar.

 Alarm options

You can customise the behaviour of alarms and alerts from the ShareScope options dialog. There

have been significant changes to this dialog box for both ShareScope Gold and Plus/Pro.

To access alarm options go to:

Tools: Options: End-of-day alarms for ShareScope Gold/Plus/Pro.

Tools: Options: Intraday alarms for ShareScope Plus/Pro.

For further information on individual settings within either alarms tab please see ShareScope help.

Remember, if you have any trouble finding or using any of these features, please don’t hesitate to

call our Customer Support team. They will be delighted to help.

From outside London: 0845 045 0111

From London: 020 7749 8504

Email: support@sharescope.co.uk
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