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sShareScope Iraining Zone

Your guide to getting the best out of ShareScope

Tutorial 18 - Exporting data from ShareScope for use in other applications

You can export much of ShareScope’s data for further analysis, for record keeping or for
presentation - to your investment club, for example.

Note: Whereas you may export tables and graphs for your own personal use or for inclusion in
Microsoft Office documents for presentation to friends or investment clubs, you must not provide
ShareScope’s data in electronic format to other individuals or organisations.

Click on the File menu and then Export to reveal the following options:

Export this share’s prices... Export the price history for the currently selected instrument.

Export prices for shares in Export prices for all the instruments in the currently selected

list... List.

Export List table... Export all the data from the currently selected List table.

Export Details (text or Export the Results data from the currently selected Details

graphic)... screen, or export the entire Details screen as an image.

Export Filter... Export Data Mining filters to share with other ShareScope
users.

Export Graph... Export the currently selected graph as an image file.

Export options... Change ShareScope’s default export options

Note: you can also use the standard Windows Copy (Ctrl-C) and Paste (Ctrl-V) functions to copy
Graphs and the Details screen into Microsoft Word or graphics packages. By default, images are
output as 600 x 400 dpi bitmaps but you can change the default size and use a vector format if
preferred. These options can be found on the Tools > Options > General dialog.

Export this share’s prices

This allows the entire price history of a share to be exported to a file for use by another program.
First make sure that the required instrument is selected. You will be asked to specify the file
format. There are four specific export formats: Excel (.csv), MetaStock (.prn), Quicken (.csq) and
General (.exp).

By default, only closing prices are exported but you can select to export OHLCV data via the Export

options.
Closing prices only format:

... 21/07/08,8.46
22/07/08,8.70
23/07/08,8.68
24/07/08,8.32
25/07/08,8.27

OHLCV format:
... 21/07/08,8.39,8.62,8.22,8.46,2454000.00

22/07/08,8.33,8.72,8.33,8.70,2928000.00
23/07/08,8.93,8.93,8.66,8.68,2612000.00
24/07/08,8.72,8.72,8.20,8.32,2781000.00
25/07/08,8.21,8.37,8.20,8.27,1446000.00
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Make sure you read the section on Export options.

Export prices for shares in a list

Instead of a single instrument, you may wish to export the prices for all the instruments in a list.
This may be one of ShareScope’s pre-set lists such as FTSE 100 or Foreign Exchange, or it may be

a Portfolio.

Again, first make sure that the List that you wish to export is currently selected. You can use this
option from the List, Historical Graph, Intraday Graph, Details, Portfolio and Data Mining screens.

Selecting this option will display the following dialog:

Export prices For all shares in lisk

— Export directory
Zi\Documents and Setkings)timc) My
DocumentsiUnit Trust Expork

),

Cancel
[~ Export to a single File: Browse, ., | Dpkions
I¥ | substitute underscares For dats in ERICS Help |
Expark
IExceI format j

— Source options

¥ Export all available data for the shares

£ Oly export data occurring afker I 140600 _I

Wied 14ER Jum 2000

This comrand will create a file of up to 1700k bytes,

By default, ShareScope will export the prices for each instrument in the list to a separate file. To
export data all instruments to one file, tick the Export to a single file option. The file(s) will be
saved in the Export directory specified in the dialog. Click on the Browse button to select a
different destination.

When exporting as separate files then the name given to each exported file is the instrument’s
EPIC code. For instruments whose EPIC includes a dot (e.g. BT.A) this would cause a syntax error,
hence the greyed out option which substitutes an underscore for the dot.

If you choose to export all instruments to the same file then ShareScope uses the filename “out”.
In the file, the prices for each instrument are preceded by its EPIC code. The issue with the syntax
is therefore no longer valid and you may disable the option to substitute underscores.

Note: you cannot export prices for a list of instruments that don’t have EPIC codes (e.g. Unit
Trusts). You will need to export these individually using the Export this share’s prices option on

the Export menu.

Notice that ShareScope indicates how large the export file will be at the foot of the dialog. If you
are exporting a group of files, this will be the combined size of the files.

Choose which export format you want to use. There are four specific export formats: Excel (.csv),
MetaStock (.prn), Quicken (.csq) and General (.exp).

Finally you can either export all available price data for the selected List or you can choose to
export data since a specific date. This feature enables only the latest prices of a list to be exported
and is particularly useful for exporting to Metastock. By default, ShareScope displays the last date
you selected. However, using the Export options, you can set this date to default to the last time
you exported data. If, for example, you always export data for the same list then this will make it
easy to export just the prices since your last export.
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Notice that there is an Options button in this dialog which will take you to the Export options.

At the end of the export process, ShareScope will inform you of how many shares were exported,
and how many were skipped.

Export List Table

You can export all the data from a List table for importing into another program such as Microsoft
Excel. This feature can be used in the List, Portfolio, Transactions, Cash Account, Data Mining,
Trades List, Broker Forecasts and Directors’ Dealings screens. First select the correct List and Table
Setting before using this feature. The table will be exported in the same format as it appears on
the screen.

Export Details screen

To allow you to perform further analysis on ShareScope data or present ideas to friends or
investment club members, ShareScope allows you to export the Details screen to a text (.csv) or
graphic file. These can be easily imported into Microsoft Office applications.

Note: you can also use the standard Windows Copy (Ctrl-C) and Paste (Ctrl-V) functions to copy
the Details screen into Microsoft Word or graphics packages.

First, display the Details screen that you wish to export and, if you are a Plus or Pro user, make
sure it is the active window.

In text format, all the information shown on the Details screen below the share name and contact
details will be exported, including the historical and forecast results figures (interim results will only
be exported if you have them currently displayed). Neither Price and Results graphs or Ranking
histograms will be exported.

Note that the resulting .csv file will need to be imported into Microsoft Excel using the Data >
Import External Data > Import Data option.

Note also that the format of the Results table is reversed in the export file. That is, each set of
results is written to a row instead of a column.

If you choose graphical format, an image of the entire Details screen will be saved to a file. Note
that the entire Details display will be exported even if the size of window obscures some of the
content. You can export using either the 16-bit Windows Metafile (.wmf) or 32-bit Enhanced
Metafile (.emf) formats which are designed for use with Microsoft Office applications.

Export filter

This feature allows you export one or more Data Mining filters for sharing with other ShareScope
users. These files are exported in a proprietary .flt format which can only be read by ShareScope.

First, go to the Data Mining screen and open the filter that you wish to export. Then select File >
Export > Export filter. You will be prompted to enter a filename and select the destination folder.

To import a filter, you must also be in the Data Mining screen. Then select File > Import >
Import a filter. When you import a filter, it will be automatically added to the list of the filters
available in the Data mining screen.

Export Graph

This feature allows you to export historical and intraday graphs and will only be available when the
active window is a Graph window.

Note: you can also use the standard Windows Copy (Ctrl-C) and Paste (Ctrl-V) functions to copy
Graphs into Microsoft Word or graphics packages.

Once selected, you will be asked to specify a filename and the file format. The graph can be saved
in the 16-bit Windows Metafile (*.wmf) or 32-bit Enhanced Metafile (*.emf) formats. These files
can be opened directly with many software packages including: Adobe Illustrator, Corel Draw and
Quark Xpress.
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Graphs exported from ShareScope include a copyright notice — please do not remove or mask this.
By default, ShareScope exports graphs at a fixed size of 600 x 400dpi. You can change this or

select to use the actual window size. These options are found on the General tab of the Options
dialog which is accessed via the Tools menu (shown below).

ShareScope Options el |

CUfrencies I Inkraday history I Intraday alarms I End-of-day alarms I

Lists I araph I Mews I Partfalios & Transactions I
Communications I Intraday Feed I Market hours I Lewvel Z Feed General

B FastEF‘ICFmdnptlnns [ Auto-save every I 0 minukes

Iw Enable pop-up data tips on all views
¥ ask 'Fast EPIC find' question

— Clipboard options

— Calculator options %' Copy as a bitmap

(¥ Use ShareScope calculator " Copy as a vector image {more Flexible)

[ Show memory buttons

— Clipboard & Expork image size
[ show memary walue

[ show calculation

i~ Lse window size

% Use fixed size  Width |5|:u:|

[ Show large buttons

Height | 400
™ Use default Windows calculator
— InfoZentre options
— Daka Mining
W Use wizard ko add & edit criteria Settings | Reset al |
— ShareScripk

Ise editar I O

[ Prompt me if scripts rum For a long kime without berminating

Ik I Cancel | Help |

Export options

You can re-configure some of ShareScope’s default export options to suit your requirements. This
dialog can be accessed from the File > Export menu.
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— Date Format — Field separators
fe |Jze Tab
" Month Day Year = Use comma
" Year Month Day " Other characker I

™ Four digit vear
[¥ Date separataor I,l'
ZSth May 2000; 25/05/00

Date and field separator Formats are used when no specific Format (Excel, Metastock
or Quicken) is chosen during File export

[+ Use adjusted prices

[ Include the latest price line when exporting a transaction table
[ Include ©HLCY information when exporting a share's history
[ Export prices as pence (or equivalent)

[ Do not include a header line § Metastock and general Formats

[ Defaulk 'export after' date to last date when data were exported

Help Zancel | K I

Date format
These options allow you to choose how the date will be exported. The format you choose is
displayed at the bottom of this section.

Field separators
You can choose one of two set field separators, or you can customise your own by selecting Other
character and entering your chosen character in the box.

Use adjusted prices
By default, ShareScope will export prices adjusted for splits and consolidations. Untick this option
to export unadjusted prices. ShareScope’s graphs use adjusted prices.

Include the latest price line when exporting a transaction table
The Latest lines give a summary of your transactions for each instrument - that is, your net
position. Tick this option to include the Latest lines; untick to exclude them.

Include OHLCV information when exporting a share’s history
By default, ShareScope exports closing prices only. Tick this option to export open, high, low, close
and volume data.

Export prices as pence (or equivalent)
This option exports prices in their minor currency unit.

Do not include a header line (Metastock and general formats)
This option allows you to omit the header line (name of instrument) from a MetaStock or general
format file.

Default 'export after’' date to last date when data were exported

When you export the price histories of the instruments in a List, you can choose to export data
from a specific date. If you tick this option, ShareScope will remember and display the last date on
which you performed an update. This feature is useful if you periodically export the prices for the
same list of shares.

Note: if, when you export, you choose a specific format (Excel, MetaStock or Quicken) this will
override the settings in this dialog.

Remember, if you have any trouble finding or using any of these features, please don’t hesitate to
call our Customer Support team. They will be delighted to help.

From outside London: 0845 045 0111
From London: 020 7749 8504
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Email: support@sharescope.co.uk
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